Новости экономики и финансов. Курсы валют, ситуация на биржах, акции, котировки, аналитика: 💫 💫 💫 💫 💫 читайте на сайте

1C Выделить Жирным Ячейку Табличной Части • Специальные предложения

Для этого мы используем серверную процедуру ПриСозданииНаСервере в которой получим ссылку на документ и заполним реквизит Товары результатом запроса к табличной части документа.

Мнение эксперта
1С:Эксперт по технологическим вопросам
Задавайте мне вопросы, и я помогу разобраться!
Затем при помощи метода ОповеститьОВыборе из формы подбора посылаем оповещение владельцу формы о завершении подбора и передаем владельцу формы адрес во временном хранилище, где размещается созданная таблица значений. Вывод части текста жирным в табличном документе Обращайтесь в форму связи

Вывод части текста жирным в табличном документе

Скачать файлы

Специальные предложения

Лучше уж на ячейки разбить и оформление поменять. Ну или макет в Word.
Если я захочу потом выделить жирный текст и погуглить его?

(4) О, это такой же как знаменитый шрифт Komsomolskaya pravda, только наклонен чуть в сторону запада.

(8) Это упрёк или так. занудство? Что тут крамольного «Макет = РеквизитФормыВЗначение(«Объект»).ПолучитьМакет(«Макет»)»?!

АП: И туда же, в копилку антипроизводительности, передача ТабличногоДокумента с сервера на клиент. Уж не знаю, почему 1с не оптимизировала это действие на уровне платформы, да еще и в типовых так же делает. Но большой таблдок может передаваться пару минут (даже на одном хосте), а если через временное хранилище — пролазит даже по сетке за секунду.

(11) [IS-QUOTE] >> Здесь: почему бы макет не получить из менеджера и БЕЗ контекстного вызова? Из менеджера конечно можно, а если это внешняя печатная форма или обработка, тогда как?! Ваше решение?

>>И туда же, в копилку антипроизводительности, передача ТабличногоДокумента с сервера на клиентАналогично. Ваше решение для ВПФ.

В аду есть котел специально для таких упырей, которые не соблюдают форматирование и херачат все в одну строку без пробелов и разделителей. Блевать хочется при чтении такого кода.

(9)Каких именно вам не хватает разделителей. И для чего?
Вам важно какую-то строку или знак выделить? Он особенный? На нём важно сконцентрировать внимание? При чтении кода именно он должен бросаться в глаза?

Спасибо автору, я тут смотрю некоторые против кода и тд. Мое личное мнение если есть замена текущему решению то показать его и уже потом можно сказать чем лучше новое решение и чем хуже старое а если нету чем заменить решение лучше не трогать текущее решение.

(19) Доброе утро! Нужен редактор шрифтов и в шрифте поменять одни символы на другие. Я заменил символы старой кириллицы (они уж точно не используются) на жирные и потом подменой выводил их. Потом делаешь строку замены.

Какую часть дохода тратите на еду?
До 50%Больше 50%

Добрый день, купила у вас. Какая то после замены тарабарщина вмсето русского языка( Это означает шрифт не подключился? У меня баха sql-ная.

Добрый вечер! Да, если «тарабарщина», то в системе не зарегистрирован шрифт или он не выбран в макете.

(24) Добрый день! Платформа на это не влияет. Тут два варианта, — в системе не зарегистрирован шрифт или он не выбран в макете. Причем, если вы работаете под сервером, например через RemoteAPP, то шрифт должен быть установлен на сервере.

Приветствую коллеги.
В принципе у меня все работает , но есть неудобство если копировать текст из ячейки с этим шрифтом в буфер и вставлять то получаются так называемы крякозябы, подскажите может кто в курсе как с этим бороться ?

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом.

Решение задач по управляемым формам — Тема № 10: Как реализовать заполнение табличной части документа при помощи формы подбора, Курсы по 1С

Первым делом отключаем стандартную обработку события, чтобы при двойном щелчке мышью по списку номенклатуры не открывалась форма элемента справочника, а выполнялось только добавление номенклатуры в корзину.

Мнение эксперта
1С:Эксперт по технологическим вопросам
Задавайте мне вопросы, и я помогу разобраться!
Возвращает значение одного из трех типов в зависимости от источника таблицы формы ДанныеФормыСтруктура, ДанныеФормыЭлементКоллекции, ДанныеФормыЭлементДерева. Данные строки 1С — метод таблицы формы. Обращайтесь в форму связи

Реализация на платформе 1С: Предприятие 8.2 (8.3 управляемое приложение)

Пусть в нашей конфигурации есть документ “ВводОстатковДолга” с табличной частью “Контрагенты” (с колонками “Контрагент” и “Сумма”). В свою очередь у справочника “Контрагенты” есть реквизит “ИНН”, значение которого необходимо выводить в строках табличного поля.

Откроем управляемую форму документа, добавим новую колонку “ИНН” реквизита “Контрагенты” и перенесём её на закладку “Элементы” (для отображения в форме).

Откроем палитру свойств поля “КонтрагентыКонтрагент” и добавим обработчик события “ПриИзменении”

// служебная функция получения значения реквизита объекта (выполняется на сервере)
&НаСервере
Функция ЗначениеРеквизита ( Объект , ИмяРеквизита ) ;
Возврат Объект [ ИмяРеквизита ] ;
КонецФункции

// обработчик события «ПриИзменении» поля «Контрагент» в табличном поле «Контрагенты»
&НаКлиенте
Процедура КонтрагентыКонтрагентПриИзменении ( Элемент )
ТекДанные = Элементы . Контрагенты . ТекущиеДанные ;
ТекДанные . ИНН = ЗначениеРеквизита ( ТекДанные . Контрагент , «ИНН» ) ;
КонецПроцедуры

Горящие товары с бесплатной доставкой
 «AliExpress Россия» работает отдельно от глобального «AliExpress» принадлежащего Alibaba. Он не зависит от мировых банковских систем и не попал под санкционный список со стороны США и Великобритании. Из Китая соответственно тоже можно заказывать ничего не опасаясь.

Это обеспечит нам изменение значения поля “ИНН” при выборе контрагента в строке табличного поля.
Теперь необходимо предусмотреть заполнение колонки “ИНН” при открытии формы документа, а так же после записи и при чтении на сервере.

Обновление данных после записи и при чтении на сервере необходимо в связи с тем, что иначе значения колонки “ИНН” будут очищаться каждый раз при возникновении этих событий. Для заполнения колонки “ИНН” опишем в модуле формы служебную серверную процедуру:

Затем добавим в модуль формы документа обработчики событий “ПриОткрытии”, “ПриЧтенииНаСервере” и “ПослеЗаписиНаСервере”, в каждой из которых будем вызвать описанную ранее служебную процедуру “ОбновитьДанныеКолонкиИНН”

1С изменить значение в табличной части документа

Дополнительная вычисляемая колонка в табличной части

В начале коротко о том, как добавить дополнительную колонку в табличное поле на платформе 1С 8.1.

Предположим, что у нас есть некий документ с табличной частью “Товары” (с колонками “Номенклатура” и “Количество”) и нам нужно вывести дополнительную колонку “Цена”, которая бы содержала данные реквизита “Цена” элементов справочника “Номенклатура”, выбранных в строках табличной части.

Для этого нам достаточно добавить в форме документа новую колонку “Цена” в табличное поле, содержащее данные табличной части документа и написать следующий код в обработчике события “ПриПолученииДанных” этого табличного поля:

Хочу обратить внимание на то, что строки табличного поля обрабатываются порциями, по мере прокрутки списка.

Первым делом отключаем стандартную обработку события, чтобы при двойном щелчке мышью по списку номенклатуры не открывалась форма элемента справочника, а выполнялось только добавление номенклатуры в корзину.

Мнение эксперта
1С:Эксперт по технологическим вопросам
Задавайте мне вопросы, и я помогу разобраться!
Возвращает значение одного из трех типов в зависимости от источника таблицы формы ДанныеФормыСтруктура, ДанныеФормыЭлементКоллекции, ДанныеФормыЭлементДерева. 1с 8.3 табличная часть документа Обращайтесь в форму связи

1C Выделить Жирным Ячейку Табличной Части

Вы разрабатываете некую форму, на ней у вас есть табличное поле привязанное к списку какого-либо справочника. И вы хотите реализовать механизм отметки нужных строк галочками.

Делается очень просто! Для этого вы добавляете новую колонку, через контекстное меню.

Называете ее «Отметка». Выбираете элемент управления Флажок.

Затем создаете реквизит ОтмеченныеСтроки с типом СписокЗначений, в нем будем хранить какие строки отметили.

У табличного поля задействуем два события, первое ПриВыводеСтроки, сробатывает всякий раз, когда система выводит строку табличного поля и ПриИзмененииФлажка, когда пользователь изменяет состояние флажка в колонках табличного поля.

Процедура ТабличноеПоле1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
ОформлениеСтроки.Ячейки.Отметка.ОтображатьФлажок = Истина;
Если ОтмеченныеСтроки.НайтиПоЗначению(ДанныеСтроки.Ссылка) = Неопределено Тогда
ОформлениеСтроки.Ячейки.Отметка.Флажок = Ложь;
Иначе
ОформлениеСтроки.Ячейки.Отметка.Флажок = Истина;
КонецЕсли;
КонецПроцедуры

Обрабатываем только колонку Отметка. Если в списке значений уже есть строка, по которой кликнули, то ее удаляем, это означает снятие галочки. И наоборот, если текущей строки нет — добавляем.

В дополнение было бы весьма удобно реализовать механизмы отметить и снять все галочки! Располагаете на форме командную панель, на ней две кнопки. По нажатию на одной выполняете процедуру:

Процедура КоманднаяПанельДействиеОтметитьВсе(Кнопка)
Выборка = Справочники.Пользователи.Выбрать();
Пока Выборка.Следующий() цикл
ОтмеченныеСтроки.Добавить(Выборка.Ссылка);
КонецЦикла;
ЭтаФорма.Обновить();
КонецПроцедуры

Здесь в цикле перебираются все записи (в данном случае это справочник пользователи, поэтому перебираем выборку) и добавляются с список значений ОтмеченныеСтроки. После выполняется перерисовка формы.

Процедура КоманднаяПанельДействиеСнятьВсе(Кнопка)
ОтмеченныеПользователи.Очистить();
ЭтаФорма.Обновить();
КонецПроцедуры

В итоге у вас получится вот такая табличная часть с дополнительной колонкой Отметка, где выбираются нужные строки, они будут попадать в список значений ОтмеченныеСтроки. И в дальнейшем, перебирая ОтмеченныеСтроки сможете производить с ними какие либо действия! Над таблицей есть две кнопки, установить все галочки и снять!

Собрание полезных заметок Shirrma: 1С галочки для табличного поля

💥Принимайте участие в опросе и получайте бесплатную консультацию

Related posts

Добавить комментарий

*