Новости экономики и финансов. Курсы валют, ситуация на биржах, акции, котировки, аналитика: 💫 💫 💫 💫 💫 💫 читайте на сайте

1C Управляемая Форма в Той же Колонке • Чтение данных

Чтобы это сделать проматываем список других настроек вниз и устанавливаем поля Выводить заголовок и Заголовок как на рисунке ниже.

Мнение эксперта
1С:Эксперт по технологическим вопросам
Задавайте мне вопросы, и я помогу разобраться!
При этом состав пользовательских настроек описывается в каждом варианте отчета исходя из того, какие настройки нужны именно для конкретного варианта. Программное добавление и изменение элементов управляемых форм. Обращайтесь в форму связи

Как работает условное оформление 1с

В управляемом интерфейсе (УФ), для этого предназначен универсальный механизм «условного оформления». Настройку раскраски можно выполнить в двух вариантах. Первый, в конфигураторе мыщью в форме задать необходимые настройки, второй задать эти же настройки «кодом». Рассмотрим эти варианты.

  1. Задать мышью условное оформление в форме.
  1. Открыть в конфигураторе свойства формы (выделить самый корень слева в окне отображения реквизитов)
  2. Далее через кнопку «+» добавить необходимое оформление для строк. В первой колонке задается как именно оформлять строку, во второй колонке при каких условиях сработает эта строка оформления, в третьей колонке что именно будет оформлено (если выбрать просто название таблицы, то целиком строка, если выбрать одну из колонок, то соответственно эта колонка).
  3. Результат оформления:
  4. Данная процедура производит раскраску в строке только той ячейки, которая по своему значению равна значению в другой колонке «ЛучшаяЦена».
  5. Также внизу процедуры есть код, по которому все колонки имена которых начинаются с «ЦенаИнформативная_» закрашиваются в серый цвет.
  6. Результат оформления:

Система компоновки данных 1С 8.3 для начинающих: меняем созданный отчет

Условное оформление управляемой формы в 1С

Следует заменить, что условное оформление форм работает только в конфигурациях использующих управляемое приложение (Бухгалтерия 3.0, ЗУП 3.0/3.1, Управление торговлей 11 и т.п.)

Условное оформление 1с. Интерактивная настройка

Еще один плюс условного оформления — его можно настроить не написав ни строчки кода. Для этого в форме необходимо:

  • Открыть свойства формы -> вкладка оформление -> УсловноеОформление Открыть;
  • Откроется таблица Настройка условного оформления;
  • В первом столбце необходимо выбрать оформление (или сразу несколько);
  • Во втором столбце задать условие, по которому будет срабатывать выбранное оформление;
  • С третьем столбце необходимо выбрать элементы формы на которые будет действовать выбранное оформление.

Обратите внимание, что условное оформление действует только на колонки таблиц формы. Другие элементы формы вы тоже можете выбрать в колонке Оформляемые поля, но это не даст никакого результата.

Условное оформление формы. Пример интерактивной настройки

Для примера мной была написана простейшая обработка, на формы которой добавлен реквизит с типом ТаблицаЗначений, с тремя колонками. А также три реквизита с типом булево. Скачать обработку можно Здесь.

Настроим следующее условное оформление данной формы: при установке реквизита СкрытьКолонку1 в значение Истина, в таблице форме скрывать реквизит Колонка1.

  • В колонке Условие нажмем на кнопку с тремя точками, в открывшемся окне добавим новый отбор. Пропишем туда следующие значения: Левое значение — СкрытьКолонку1, Вид сравнения — Равно, Правое значение — Да;
  • В колонке Оформляемые поля нажмем на кнопку с тремя точками, в открывшемся окне добавим новый элемент, и выберем значение ТаблицаФормыКолонка1;
  • В итоге у нас должна получиться настройка условного оформления, такая же как на следующем рисунке;

Условное оформление 8.3. Пример программной настройки

Используя ту же внешнюю обработку, что и в предыдущем пункте, приведем пример программной настройки условного оформления. Необходимо сделать следующее: при установке реквизита ПоменятьЦветКолонки2 в значение Истина, в таблице формы раскрашивать фон Колонки 2, при установке реквизита СделатьНедоступнойКолонку3 в значение Истина, в таблице формы делать недоступным реквизит Колонка3.

Промокоды на Лайм Займ на скидки

Займы для физических лиц под низкий процент

  • 💲Сумма: от 2 000 до 70 000 рублей
  • 🕑Срок: от 7 до 168 дней
  • 👍Первый заём для новых клиентов — 0%, повторный — скидка -10 % по промокоду

В модуле формы создадим серверную процедуру, назовем ее УстановитьУсловноеОформление и сразу же допишем ее вызов в процедуре ПриСозданииНаСервере.

Весь следующий код будем писать в процедуре УстановитьУсловноеОформление. Нам необходимо добавить новый элемент условного оформления формы, для этого используем стандартную коллекцию формы УсловноеОформление.

Для этого в реквизитах формы создадим таблицу значений, которую назовем СвязьКомандыИСклада, у этой таблицы будут две колонки ИмяКоманды и Склад.

Мнение эксперта
1С:Эксперт по технологическим вопросам
Задавайте мне вопросы, и я помогу разобраться!
Проверим, не содержится ли в текущей строке значение Неопределено , и если всё нормально, то вызовем процедуру в серверном контексте, в которой уже будем непосредственно работать с контекстным меню. Управляемые формы Обращайтесь в форму связи

1С 8.3 Программное создание таблицы значений на форме в управляемом приложении — Программист 1С Минск. Автоматизация бизнеса.

// Описание таблицы значений как реквизита
МассивТипа = Новый Массив ;
МассивТипа . Добавить ( Тип ( «ТаблицаЗначений» ));

// Добавление ТаблицыЗначений в массив реквизитов
ОписаниеТипа = Новый ОписаниеТипов ( МассивТипа );
МассивРеквизитовФормы = Новый Массив ;
МассивРеквизитовФормы . Добавить (Новый РеквизитФормы ( «ТаблицаСотрудников» , ОписаниеТипа , «» , «ТЗСотр» ));

// Создание ТаблицыЗначений с описанием колонок
КвалификаторыСтроки = Новый КвалификаторыСтроки ( 10 );
ОписаниеСтроки_10 = Новый ОписаниеТипов ( «Строка» , , КвалификаторыСтроки );

Горящие товары с бесплатной доставкой
 «AliExpress Россия» работает отдельно от глобального «AliExpress» принадлежащего Alibaba. Он не зависит от мировых банковских систем и не попал под санкционный список со стороны США и Великобритании. Из Китая соответственно тоже можно заказывать ничего не опасаясь.

ОписаниеСотрудника = Новый ОписаниеТипов ( «СправочникСсылка.Сотрудники» );

ТЗ = Новый ТаблицаЗначений ;
ТЗ . Колонки . Добавить ( «Код» , ОписаниеСтроки_10 );
ТЗ . Колонки . Добавить ( «Сотрудник» , ОписаниеСотрудника );
// ТЗ.Колонки.Добавить — можно и в цикле

// Добавление в массив реквизитов колонок ТаблицыЗначений
Для Каждого Колонка Из ТЗ . Колонки Цикл
МассивРеквизитовФормы . Добавить (Новый РеквизитФормы ( Колонка . Имя , Колонка . ТипЗначения , «ТаблицаСотрудников» ));
КонецЦикла;

// Удаление — если таблица существует
ЭлементТаблица = Элементы . Найти ( «ТаблицаСотрудников» );
Если ЭлементТаблица Неопределено Тогда
Элементы . Удалить ( ЭлементТаблица );
Иначе
ИзменитьРеквизиты ( МассивРеквизитовФормы );
КонецЕсли;

// Добавление ТаблицыЗначений на форму
ТаблицаПолейВыбора = Элементы . Добавить ( «ТЗСотр» , Тип ( «ТаблицаФормы» ));
ТаблицаПолейВыбора . ПутьКДанным = «ТаблицаСотрудников» ;
ТаблицаПолейВыбора . Отображение = ОтображениеТаблицы . Список ;
ТаблицаПолейВыбора . ПоложениеКоманднойПанели = ПоложениеКоманднойПанелиЭлементаФормы . Нет ; // Отключение командной панели

НовыйЭлемент = Элементы . Добавить ( Колонка . Имя , Тип ( «ПолеФормы» ), ТаблицаПолейВыбора );
НовыйЭлемент . Вид = ВидПоляФормы . ПолеВвода ;
НовыйЭлемент . ПутьКДанным = «ТаблицаСотрудников.» + Колонка . Имя ;
НовыйЭлемент . Ширина = 10 ;

// Заполнение ТаблицыЗначений
Запрос = Новый Запрос ;
Запрос . Текст =
«ВЫБРАТЬ
| Сотрудники.Код КАК Код,
| Сотрудники.ГоловнаяОрганизация КАК ГоловнаяОрганизация,
| Сотрудники.Ссылка КАК Ссылка,
| Сотрудники.Наименование КАК Наименование
|ИЗ
| Справочник.Сотрудники КАК Сотрудники
|
|УПОРЯДОЧИТЬ ПО
| Наименование» ;

ВыборкаДетальныеЗаписи = РезультатЗапроса . Выбрать ();
Пока ВыборкаДетальныеЗаписи . Следующий () Цикл
Строка = ТЗ . Добавить ();
Строка . Код = ВыборкаДетальныеЗаписи . Код ;
Строка . Сотрудник = ВыборкаДетальныеЗаписи . Ссылка ;
КонецЦикла;

// Передача ТаблицыЗначений в реквизит формы
ЗначениеВРеквизитФормы ( ТЗ , «ТаблицаСотрудников» );

Алгоритм инициализации управляемой формы 1С | Секреты 1С: Эксперта | Яндекс Дзен

Для команд, выполнение которых приводит к изменению данных в информационной базе, следует выбирать категорию Панель действий для независимых команд или Командная панель формы для параметризуемых команд.

Мнение эксперта
1С:Эксперт по технологическим вопросам
Задавайте мне вопросы, и я помогу разобраться!
На этапе непосредственной компоновки УФ ПриСозданииНаСервере , уже отсутствует параметр ТекущийОбъект , который содержит экземпляр_ СУБД , т. Как работает условное оформление 1с Обращайтесь в форму связи

Чтение данных

На этом этапе, в случае, если был создан Текущий объект, то все его данные считываются в основной реквизит УФ. Другими словами, делается копия только необходимых данных экземпляра_ СУБД , которые мы определили в построителе УФ в конфигураторе.

После этого мы можем выполнять свои действия с формой в процедуре ПриЧтенииНаСервере , в этой процедуре нам еще доступен экземпляр_ СУБД как параметр ТекущийОбъект процедуры.

После того, как все необходимые нам данные были считаны из экземпляра_ СУБД в реквизит формы (создалась копия), были выполнены все наши дополнительные действия, экземпляр_ СУБД (Текущий объект) уничтожается, т.е. удаляется из памяти сервера 1С.

1с программно выполнить общую команду.

💥Принимайте участие в опросе и получайте бесплатную консультацию

Related posts

Добавить комментарий

*